Problem: url for my site directs to a partial page with dead links


Hi,
I suggest taking a look if your permalink option is correct.
On your WordPress dashboard go to > Settings > Permalinks
Cheers!

The problem is that I can no longer reach my WordPress dashboard through my url and I know of no other way of getting there…any ideas?

Thanks very much in advance.

I never used Linode server but in some servers you can login to your WP installation from their control panel.
Maybe try to open a support chat with Linode to ask if they have this feature?

I’m waiting for an answer form Linode, but in the meantime I’ve discovered the note below on a page detailing how to install WordPress. The problem is that I have no idea how to access the VirtualHosts codeblock on my WordPress site. Any ideas? I can get into my server using terminal, and know how to use an editor, but can’f find this file.

Note
If using permalinks to set your posts’ URLs, Apache will need to be updated to allow individual sites to update the .htaccess file. To permit this, add the following to you WordPress website’s VirtualHosts code block:

1
2
3
4
5
<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride All
Require all granted
</Directory>
You will now be able to login to your new WordPress-powered website. You can continue the configuration of your WordPress site from the web-based interface.

Congratulations! You have now successfully installed WordPress.



Source link