Old Posts and Pages Won’t Update (Difficult Mystery to Solve)


I recently started having an error with my site in which I cannot update old posts.

It’s a very odd error because I can make new posts and update them, but I can’t update old posts (change the title, description, content, nothing can be updated)…

But I can revert back to old revisions for some reason!

I use WordPress’s Gutenberg editor to edit metadata like the title and Yoast SEO for the description tag and then I use thrive architect for content!

My content can’t be updated in thrive architect either. Every time I hit “Save and Exit” in thrive, it logs me out of WordPress.

When I try to update old pages in Gutenberg editor it either takes for ever to load then when it finally loads, it reverts all the changes I made back to what it was before I made changes OR it’ll redirect me to my “Posts” page in WordPress where it shows all my posts I have.

Yes, I’ve deleted all my cookies and cache from my browser and Yes, I’ve deactivated all my plugins then logged out and logged back in then tried it and it still didn’t work so I reactivated my plugins.

Yes my server is up to date with WordPress Theme Requirements (PHP 7.1 or 7.3 or something like that)

I’ve contacted my hosting provider twice and they’re clueless. Then I contacted my theme creator and they said my site and their theme looked fine.. They didn’t see anything wrong.

So I’m completely stumped and I don’t know what to do!

I’m going to need the absolute best of the best of WordPress experts here to help with this one cause it’s quite the dilemma and mystery.

  • This topic was modified 1 day, 18 hours ago by MP.



Source link