I couldn’t access wp-admin | WordPress.org

I couldn’t access wp-admin

Can you access the public website http://www.medialinks.com.bh/ but cannot access the the admin dashboard only?

I checked your site but even the public website doesn’t work. I’m getting the same DNS problem you’re reporting.

This just means your domain is not properly configured to point to your Plesk hosting server (or maybe the change was done recently and it’s NOT taken effect yet).

This is not a WordPress issue — you’ll need to contact your host to resolve this.

(To test if what I’m saying is true or not, upload an image named test.jpg to the root of your website. If your domain and hosting are configured properly, you should be able to view this image in your browser by going to http://www.medialinks.com.bh/test.jpg . This image obviously has nothing to do with WordPress, so if you can’t view this image link as well, then it just proves what I’m saying that this is not a WordPress issue.)

By the way, who is your host?

Hi George Appiah,
Thank you for you reply. I cannot access both admin dashboard and the public website. My host is “www.batelco.com”. They are a regional telecom company which provides hosting services as well. I have installed wordpress along with the themeset and jetpack. But nothing shows as of now.

I tried what you had said here. I uploaded an iamge named test and

“The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.”

This is the response i received. So this is a hosting issue i think right? I am asking this because, Previously it worked well, i mean before installing the wordpress. I had created a basic website with muse and uplaoded it to the server via ftp a few years back and it worked fine. Day before yesterday I installed wordpress and this showed up.

Hello,

Thanks for the update.

It appears the DNS issue is resolved now. I can now view the website, but instead of the expected WordPress site, I’m seeing the message:

The website is undergoing scheduled maintenance.
Sorry for the inconvenience. Come back a bit later, we will be ready soon!

Powered by Plesk

Did you put this there yourself?

Check your website directory so see if there’s an index.htm/index.html file there, and rename it to something else.

Hi,
I put the website under maintenance mode to avoid clients viewing some errors than our real website.

In the WordPress toolkit section I saw an option called maintenance mode. Here is the screenshot of that.

https://paste.pics/627e9583d975cd6f1caf4ede16aa5f8d”

This is the screenshot of my current Home Directory

https://paste.pics/bfbd0df7556e79c4768452595f88e067”

There are no index.html files. However I was able to find out one index.php file inside the “httpdocs” folder which is shown in the above screenshot.

  • This reply was modified 1 day, 20 hours ago by deepakajith.

The index.php file is part of WordPress (if that’s the directory where WordPress is installed) and should be left there.

And WordPress seems to be working… because the “Maintenance” page seen on the site is actually loaded from WordPress (I believe you used the “maintenance mode” toggle in Plesk).

What happens now when you click on “LOG IN” from the Plesk dashboard?

Yes, I used used the “maintenance mode” toggle in Plesk.

here is the result i got when i tried to click on login from the plesk dashboard.

https://paste.pics/66bb85fce6dbb273b1cc7fe9c02981b0

Ok, I think I’ve gotten to the bottom of this 😀

It looks like you’ve pointed the sub-domain www.medialinks.com.bh to the server, but not the root domain medialinks.com.bh .

So…

http://www.medialinks.com.bh/ — resolves and goes to your “maintenance” page.

But…

http://medialinks.com.bh/ — does not resolve and gives the DNS error.

Meanwhile, your WordPress site was installed without the www prefix, so this is what Plesk has in its configuration, and clicking the “LOG IN” link in Plesk takes you to http://medialinks.com.bh/wp-login.php — which doesn’t resolve at all.

So kindly check your domain’s DNS setup and make sure the root/naked domain medialinks.com.bh is also pointed to the server.

I really appreciate the patience and the valuable time you are spending for me!!

I don’t see a DNS setup option inside the Plesk to check this. I only got hosting settings option and there isn’t anything pretty much we could do inside it. Most of the options are turned either green or grey and cannot be edited. This is the screenshot.

https://paste.pics/10afcf024cbaea0798caabc8e0b5ebf2

By the way, even if i add a www in here and try it’s only showing me the maintenance message not the login page.

http://www.medialinks.com.bh/wp-login.php

However, When I use the preview mode which u can see in here
https://paste.pics/7291eb6298b116e98d3c015b04b40050

i am getting completely a different result.
this is the result:

https://paste.pics/d5e09cb313059473acc5c77f219cdef4

  • This reply was modified 1 day, 19 hours ago by deepakajith.

By the way, even if i add a www in here and try it’s only showing me the maintenance message not the login page.

http://www.medialinks.com.bh/wp-login.php

The maintenance page takes over EVERYTHING, including the admin login page.

You can temporarily switch off the maintenance toggle, and you should be able to log in from the www URL above (or at you’ll see a different message).

I don’t see a DNS setup option inside the Plesk to check this. I only got hosting settings option and there isn’t anything pretty much we could do inside it. Most of the options are turned either green or grey and cannot be edited. This is the screenshot.

How did you link or point the domain to the hosting account initially?

If you purchased the domain name and hosting from the same company and they did the setup for you, you should contact their support to let them know you’re unable to access your website without the www prefix (ie http://www.medialinks.com.bh works, but medialinks.com.bh does not work). They should fix this.

I tried switching the maintenance mode off now and tried accessing the link again but it leads me to the same DNS error nothing else shows up.

I didnt point the domain earlier everything is done by the hosting providers itself. I will contact them and let you know the Updates.

Thank you so much for the support man.

Have a good day!

I tried switching the maintenance mode off now and tried accessing the link again but it leads me to the same DNS error nothing else shows up.

My bad… I forgot that this will redirect you to the non-www link configured in your WordPress database, which we know doesn’t work.

To solve this, you’ll have to configure your WordPress site to use the www prefix.

1) Open PHPMyAdmin from your Plesk console, and open your WordPress database from the drop-down.

2) Look for and click the wp_options table (the wp_ part may be different if you used a different table prefix while setting up your WordPress site with Plesk)

3) Once you open this table, look for the two rows shown below, click and change each one from http://medialinks.com.bh to http://www.medialinks.com.bh and save it (there should be a tiny “Go” link somewhere, that’s the SAVE button 😀 )

—–

As an alternative to making this change directly in your database as described above, you can open your wp-config.php file (in the root of the folder where WordPress is installed) and add the following two lines just above the line that says ‘That’s all, stop editing! Happy publishing’.

define( 'WP_HOME', 'http://www.medialinks.com.bh' );
define( 'WP_SITEURL', 'http://www.medialinks.com.bh' );

Consider this alternative a temporary fix, and remove it once you can confirm that http://medialinks.com.bh (ie without www) works.

I could only see this when I open PHPMyAdmin
https://paste.pics/2b9aae601aa1dfa76a9275b241b5852b

I just tried the alternative method as well.
It also doesn’t works. Still the DNS error is only showing up.

here is the screenshot of the added code

https://paste.pics/bf2f73c6fab2df8394b3cbc2b7dae203

  • This reply was modified 1 day, 18 hours ago by deepakajith.
  • This reply was modified 1 day, 18 hours ago by deepakajith.

Hello,

I suppose you’re good now?

The DNS issue seems to be resolved now, and I can now access your website both with and without the www prefix. Below is what I see now.

If you’re still seeing the DNS error, this must be due to a stale DNS cache on your computer or at your ISP. You can flush your computer’s DNS or temporarily switch your computer to use a public DNS server — or just wait for a while for the Intertubes to sort themselves out 😀

The Problem is still there. I couldn’t see any change in error. And even in my mobile,
http://www.medialinks.com.bh/wp-admin as well as medialinks.com.bh/wp-admin leads to the same page you got now.

however, I have contacted the hosting team and they told me they will let me know the updates.

http://www.medialinks.com.bh/wp-admin as well as medialinks.com.bh/wp-admin leads to the same page you got now.

That’s because the maintenance mode is ON.

With the DNS issue resolved now, you should be able to click on the “LOG IN” link from Plesk and get access to the dashboard. Alternatively, you could disable the maintenance mode just to test.

I’m quite confident you should have access to the dashboard now.



Source link