Change main website site url from http to https for Multisite

Artan

(@artankrasniqi1988)

Someone from the German wordpress.org site helped me out with a link form Stack Exchange. So in case someone had the same issue, here is a possible solution that helped me out. That´s his words regarding to this link: https://wordpress.stackexchange.com/a/355888/129212

“Workaround:

1.) Make a backup of the database. No backup, no pity.

2.) In wp-config.php, comment out the code block for multisite with the prefix // in front of each line (do not delete).

Analogous:

// define ('WP_ALLOW_MULTISITE', true);
// define ('MULTISITE', true);
// define ('SUBDOMAIN_INSTALL', true);
// $ base = '/';
// define ('DOMAIN_CURRENT_SITE', 'example.com');
// define ('PATH_CURRENT_SITE', '/');
// define ('SITE_ID_CURRENT_SITE', 1);
// define ('BLOG_ID_CURRENT_SITE', 1);

3.) Login again and change the URL to https://example.com (with your domain) under Settings > General

4.) In the wp-config.php delete in the code block the comment characters // for multisite.

Analogous:

define ('WP_ALLOW_MULTISITE', true);
define ('MULTISITE', true);
define ('SUBDOMAIN_INSTALL', true);
$ base = '/';
define ('DOMAIN_CURRENT_SITE', 'example.com');
define ('PATH_CURRENT_SITE', '/');
define ('SITE_ID_CURRENT_SITE', 1);
define ('BLOG_ID_CURRENT_SITE', 1);

5.) Carry on as if nothing had happened.”

He said that it seems that WordPress didn´t consider that the main page / parent page would change in any way. So it is the easiest way to return with the previous steps to a “normal site”, change the urls and then “activate” Multisite again.

Hope it helps! See ya!



Source link