Cannot change the Link within Post/Pages

Please disable your right-click blocker if you’d like help with this.

Ian

(@plantprogrammer)

Hi, damarpaskalis, I noticed that some CSS was not properly written, and that involves two # signs being used with the link colors as seen with this code from your site:

a {
   color: ##fd5b66;
}
a:visited {
   color: ##fd5b66;
}

Assuming that you had written these CSS rules, I would remove one of the pound signs from each of these property-value pairs, so instead it should be:

a {
   color: #fd5b66;
}
a:visited {
   color: #fd5b66;
}

Since these rules don’t have particularly specific selectors, they will apply to every link on your website so I would advise that you learn more about selectors with CSS: https://developer.mozilla.org/en-US/docs/Learn/CSS/Building_blocks/Selectors

Or you could use a plug-in to ensure that the CSS code is properly formed in the future such as https://wordpress.org/plugins/so-css/

Hi @sterndata sorry for the inconvenience. I have changed the setting as soon as I got your message.

Hi @plantprogrammer, thank you for the help.
I wasn’t aware of that until you mentioned the issue here.

I fixed that and changed the CSS into something like this

.single-post .entry-content  a{
color:#fd5b66;
}

and it works the way I want it to be.

Thanks for the help, man!



Source link