Blank homepage. Internal pages are fine…

Hi All,

I’ve tried to resolve this myself but no luck yet.

As of the early hours this morning, my wordpress homepage is completely blank i.e. when you inspect through chrome, there’s literally no code.

All other pages are working perfectly fine.
Even page 2 of the homepage works fine.

I have tried…

  • Disabling all plugins
  • Increaseing memory limit in wpconfig.php
  • Clearning the cache

I have a backup from 2 weeks ago but before I revert to that.. I thought I’d ask here first.

I find this odd because it’s only my homepage that isn’t working.
All other pages are fine.
I’ve made no changes to .htaccess recently or any other files on the site, really.
I’m using the Newspaper theme by tagDiv.

One more interesting thing to note. Looking at the server error logs, we’ve been spammed with 1000s of requests from the same IP earlier today. Clearly some sort of bot. Here are a few examples of errors (site url has been replaced with ‘mysite’):

[Mon Nov 09 03:05:11.539162 2020] [proxy_fcgi:error] [pid 8017:tid 139868847970048] [client 161.97.125.50:53238] AH01071: Got error ‘Primary script unknownn’, referer: https://www.mysite.co.uk/

[Mon Nov 09 03:06:21.171073 2020] [authz_core:error] [pid 8017:tid 139868831184640] [client 161.97.125.50:57944] AH01630: client denied by server configuration: /var/www/vhosts/mysite.co.uk/httpdocs/css/libs/.htaccess~

[Mon Nov 09 03:06:51.327840 2020] [proxy_fcgi:error] [pid 8017:tid 139868873148160] [client 161.97.125.50:59010] AH01071: Got error ‘PHP message: PHP Warning: trim() expects parameter 1 to be string, array given in /var/www/vhosts/mysite.co.uk/httpdocs/mailer.php on line 41n’, referer: https://www.mysite.co.uk/

I have a suspicion that these errors and the broken homepage may not be a coincidence, although I’m very much hoping that they are!

  • This topic was modified 3 days, 1 hour ago by quaren.



Source link